Как использовать функцию поиск решения в Excel?

Применение: Excel 2003 и выше

По умолчанию функция скрыта. Открывается переходом в вкладку разработчик, нужно нажать на кнопку надстройки. Появится контекстном меню, в нём поставить галочку на «поиск решения».

После этого функция появится на вкладке «ДАННЫЕ».

С её помощью можно решить задачу с множеством неизвестных и одним желаемым значением с условиями. Например:

Есть склад, с которого нужно перевезти товар в магазин. Товар нужно уложить в фуру так чтобы вместилось максимальное количество, но не больше, чем фура способна увезти по весу.

Для решения задачи нам необходима правильная модель данных (первичные данные, ограничения и форма расчёта). Создадим таблицу с характеристиками фуры и рассчитаем общий кубический объём:

Затем создадим таблицу 2. Запишем характеристики товара неё и укажем объём товара на складе. Также как и в первой таблице рассчитаем «куб.объём» который умножает объём товара единицы товара на количество в отдельном столбце. Нам понадобится еще общий объём товара «объём фура» и общий вес товара «вес фура». Эти параметры должны меняться в зависимости от количества товара в фуре.

Завершая модель, мы должны задать ограничения, оптимизируемую функцию и изменяемые значения.

Ограничениями выберем объём товара на складе, максимальный объём фуры и грузоподъёмность

Изменяемые значения у нас будут количеством товара в фуре.

Сумма всех товаров станет оптимизируемой функцией.

Затем мы должны задать эти характеристики в поиск решения. Для удобства каждую из ячеек модели рекомендуется наименовать.

Ограничения задаются сравнением с определёнными значениями по логике (>=; <=; = ).  В примере мы связываем ограничения (общий объём и вес фуры) с суммой всех объёмов и веса товара, а также количества товара на складе.

После нажатия кнопки найти решения система произведёт расчёт и самостоятельно расставит оптимальное количество товара.

Как работает функция ЕСЛИ в Excel?

Функция ЕСЛИ – одна из самых часто используемых в Excel. Она применяется в широком кругу специалистов разных профилей для решения своих задач.

Функция ЕСЛИ проверяет, выполняется ли некоторое заданное условие, и возвращает одно значение, если оно выполняется, и другое – если не выполняется. Если условие верно, то мы говорим, что оно истинно, если неверно, то ложно. Аргументы этой функции выглядят следующим образом:

(ЛОГИЧЕСКОЕ_ВЫРАЖЕНИЕ;ЗНАЧЕНИЕ_ЕСЛИ_ИСТИНА; ЗНАЧЕНИЕ_ЕСЛИ_ЛОЖЬ)

ЛОГИЧЕСКОЕ_ВЫРАЖЕНИЕ – какое-либо значение или выражение, которое при проверке дает значение ИСТИНА либо ЛОЖЬ.

ЗНАЧЕНИЕ_ЕСЛИ_ИСТИНА ЗНАЧЕНИЕ_ЕСЛИ_ЛОЖЬ – то, что возвращается в ячейку, в зависимости от результата вычисления.

Например: Впишите данное число в ячейку А1:

А
1 950

 

 

Впишите пример функции ниже в диапазон В1:

А В
1 950 =ЕСЛИ(A2>1000;

«ИСТИНА»;»ЛОЖЬ»)

 

Если в ячейке А1 число больше 1000, то А1>1000 вернет ИСТИНА, а если больше, то ЛОЖЬ. В ячейку вернулось значение ЛОЖЬ.

Успехов Вам в изучении логических функций, друзья!

 

Как работает функция ПЕРЕКЛЮЧ?

Внимание актуально только для Excel 2013, 2016

Функция ПЕРЕКЛЮЧ (переключение) появилась недавно, в начале 2017 года. Она позволяет провести проверку ряда значений на соответствие одному выражению, при этом первое из совпавших будет возвращено в ячейку.

Рассмотрим аргументы данной функции:

=ПЕРЕКЛЮЧ(выражение; значение_1;результат_1….254)

Выражение – ваше номинальное цифровое либо текстовое выражение, с которым вы сравниваете значения

Значение_1 – ссылка на ячейку либо значение, в формуле которое будет сравниваться с выражением

Результат_1 – то что вернется в ячейку в случае успешного сравнения значения и выражения.

Немного запутанно не правда ли? Но на примере все просто:

=ПЕРЕКЛЮЧ(«ЯБЛОКИ»;»ОГУРЦЫ»;»ОГУРЦЫ ПОБЕДИЛИ»;»ЧЕРЕШНЯ»;»ЧЕРЕШНЯ_ПОБЕДИЛА»;»ЯБЛОКИ»;»ЯБЛОКИ ПОБЕДИЛИ»)

В данной выборке после сравнения будет выбрано последнее значение и система вернет в ячейку текст «ЯБЛОКИ ПОБЕДИЛИ». Пример достаточно банальный, но показывает наглядно как работает функция. Помните, что аналогичным образом можно сравнивать и цифровые значения.

Функция полезна инженерам при сравнении данных с номинальными, аналитикам, маркетологам, финансистам.

Успехов в изучении программы друзья! )

Как работает функция ЕСНД?

Функция ЕСНД – простая логическая функция работа которой заключается в проверке ячейки на ошибку НД (Нет данных). В ходе этой проверки мы можем вернуть в ячейку пользовательское любое значение либо ссылку.

Рассмотрим аргументы этой функции:

=ЕСЛИ(значение;значение_если_#Н/Д)

Значение – ссылка которая будет проверяться на наличие ошибки #Н/Д

Значение_если_#Н/Д – ссылка либо выражение, которое вернет в ячейку Excel при подтверждении наличия в значении ошибки #Н/Д

Функция применяется как вспомогательная для проверки производимых вычислений, может быть применена в различных калькуляторах, разрабатываемых в Excel. А также для изменения алгоритма расчёта других функций.

P.S Достаточно редкая в работе функция. Но все как известно иногда может пригодиться