Как работает функция ВПР?

Функция ВПР (Вертикальный просмотр) — позволяет производить поиск значения в самом левом столбце заданного диапазона и возвращать значение из указанного номера столбца.

=ВПР(значение;таблица;номер_столбца;интервальный_просмотр)
значение — любое значение в книге либо формуле которое будет искать функция ВПР
таблица — диапазон данных в котором Excel будет производить поиск

номер_столбца – номер столбца из выбранного диапазона в таблице, именно из него Excel возвращает значение

интервальный_просмотр – может иметь два аргумента ИСТИНА или ЛОЖЬ, это повлияет на выборку данных с книги Excel


1) Скопируйте данный набор значений в вашу книгу Excel в диапазон А1:C2

А B C
1 Апельсины 400
2 Мандарины 300

2) Скопируйте данный набор значений в вашу книгу Excel в диапазон E1:E2

Е

F

1 апельсины =ВПР(E1;A1:C2;3;ИСТИНА)

Если вы все сделали правильно, результатом ваших действий будет возврат числа 400 из ячейки C1, так происходит потому что система нашла значение соответствующее тому что есть в ячейке Е1 и вернула значение из третьего столбца как мы и указали в формуле.

Важно! Помните что таблица это диапазон данных который вы выбираете и именно в этом диапазоне происходит отсчёт столбцов.

Автор: Артем Долгирев

Основатель 23Academy