Функции “ИНДЕКС” и “ПОИСКПОЗ”

Сегодня поговорим об одной интересной комбинации функций, которые помогают переносить данные по двум критериям автоматически вне зависимости от структуры таблицы для переносимых данных.

Сама функция “ИНДЕКС” работает как ВПР и ГПР одновременно выполняя поиск и по строке, и по столбцу в указанной таблице и переносит те данные, которые находились на месте пересечения строки и столбца. Проблема этой формулы в том, что она не может выполнять поиск автоматически. Это решает функция “ПОИСКПОЗ” которая выполняет поиск значения и выдает номер позиции значения в искомом диапазоне.

Теперь разберем составные части данных формул и просмотрим на реальном примере, где это можно использовать:

  1. “ИНДЕКС” (Массив; Номер строки; Номер столбца)

 Массив — это Диапазон всей таблицы от начала до конца.

 Номер строки и номер столбца указывают, из какой строки и столбца будут браться данные. Эти 2 критерия будут заменяться формулой ПОИСКПОЗ.

2. “ПОИСКПОЗ” (Искомое значение;просматриваемый массив; Тип сопоставления)

Искомое значение это что мы ищем. Просматриваемый массив — это где ищем. Тип сопоставления без лишних деталей будет всегда 0

 Вот сам пример формулы =ИНДЕКС($A$1:$H$50;ПОИСКПОЗ($L$1;$C$1:$C$50;0);ПОИСКПОЗ($K2;$A$1:$H$1;0))

Суть формулы в том,что согласно номеру заказа формула сама будет искать данные по шапке нашей таблицы и подставлять без каких-либо ошибок. В “ИНДЕКС” прописывается 2 функции “ПОИСКПОЗ” первая находит номер строки, а вторая находит номер столбца.

Три важных момента при работе с этой комбинацией:

 1) Не забываем правильно закреплять ссылки (F4 меняет тип ссылки).

 2) Просматриваемый массив “ПОИСКПОЗ” должен равняться по ширине или высоте массиву “ИНДЕКС”.

 3) В столбце по которому собираетесь искать (или строке) не должно быть дубликатов

 Подробнее о том, как работает комбинация ниже в видео.